PHP 7.3 is required for WordPress 5.2 or Recommendation

WordPress 5.2 just released before few days.

Here is the system requirements, but I’m not understanding it’s require PHP 7.3 compulsory or just recommendation.

https://wordpress.org/about/requirements/

Please help me.

Answer

To be honest, everything is explained in the article you’ve linked:

To run WordPress we recommend your host supports:

  • PHP version 7.3 or greater.
  • MySQL version 5.6 or greater OR MariaDB version 10.1 or greater.
  • HTTPS support

So yes – that’s only recommendation (as WordPress definitely will work without HTTPS for example).

And later in the same article you can read that:

Note: If you are in a legacy environment where you only have older PHP
or MySQL versions, WordPress also works with PHP 5.6.20+ and MySQL
5.0+
, but these versions have reached official End Of Life and as such may expose your site to security vulnerabilities.

So you can still run WP on servers with 5.6, but it’s not recommended, because these PHP versions are not supported any more, so they can be unsecure.

Attribution
Source : Link , Question Author : Magecode , Answer Author : Krzysiek Dróżdż

Leave a Comment